360SDN.COM

首页/Tomcat/列表

启动Tomcat8出现Unsupported major.minor version 51.0错误的解决方法

来源:  2014-05-16 09:35:47    评论:0点击:

启动Tomcat8出现Unsupported major.minor version 51.0错误的解决方法

下载了个apache-tomcat-8.0.5.zip免安装压缩包,解压之后配置了CATALINA_HOME等等后启动不了。

tomcat8启动出现的错误log如下:
Using CATALINA_BASE:   "E:\apache-tomcat-8.0.5"
Using CATALINA_HOME:   "E:\apache-tomcat-8.0.5"
Using CATALINA_TMPDIR: "E:\apache-tomcat-8.0.5\temp"
Using JRE_HOME:        "D:\jdk1.6.0_31"
Using CLASSPATH:       "E:\apache-tomcat-8.0.5\bin\bootstrap.jar;E:\apache-tomcat-8.0.5\bin\tomcat-juli.jar"
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Heap

经查询此问题为java jdk和jre版本不同所致。猜测tomcat 8下部署的class是使用jdk 1.7编写并编译的,而我java_home中的jre为1.6版本的。所以就下载了一个1.7版本,将类编译成jdk 1.7版本,问题解决。

为您推荐

友情链接 |九搜汽车网 |手机ok生活信息网|ok生活信息网|ok微生活
 Powered by www.360SDN.COM   京ICP备11022651号-4 © 2012-2016 版权